ReactDom.rener is not longer supported in React 18

React 18 shipped yesterday (March 29th). ReactDOM.render has been deprecated in React18 and currently issues a warning and runs in a compatible mode.

click here to see details.

To resolve you can either revert to a previous version of React or update your index.js file to align with the React 18 syntax.

index.js

import { StrictMode } from "react";
import { createRoot } from "react-dom/client";

import App from "./App";

const rootElement = document.getElementById("root");
const root = createRoot(rootElement);

root.render(
<StrictMode>
<App />
</StrictMode>
);

For more detailed explation watch this video.

➡️ Support me

PayPal : https://paypal.me/codewitharjun

Patreon : https://www.patreon.com/codewitharjun

--

--

Install Java Jdk
Download Oracle Java Jdk :  https://www.oracle.com/java/technologies/javase-downloads.html

Commands Used :

 $ Java -version 
$ sudo dpkg -i jdk-version.deb
$ ls /user/lib/jvm $ sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/jdk-16.0.1/bin/java 1 $ sudo update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/jdk-16.0.1/bin/javac 1 $ java -version
$ javac -version

For JAVA_HOME

 $ sudo update-alternatives --config java 
$ source /etc/environment
$ echo $JAVA_HOME

Go through this video for complete instruction for Java JDK installation with JAVA_HOME

--

--